634213618f
Signed-off-by: Antoine Damhet <antoine.damhet@lse.epita.fr>
567 lines
21 KiB
Diff
567 lines
21 KiB
Diff
From 4521189274e652de6d2098337038c412501c570d Mon Sep 17 00:00:00 2001
|
|
From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
|
|
Date: Mon, 9 Mar 2020 13:10:16 -0300
|
|
Subject: [PATCH 01/20] deps-glad: Add EGL
|
|
|
|
The code is generated by https://glad.dav1d.de/
|
|
---
|
|
cmake/Modules/FindEGL.cmake | 53 ++++
|
|
deps/glad/CMakeLists.txt | 11 +-
|
|
deps/glad/include/glad/glad_egl.h | 385 ++++++++++++++++++++++++++++++
|
|
deps/glad/src/glad_egl.c | 48 ++++
|
|
4 files changed, 495 insertions(+), 2 deletions(-)
|
|
create mode 100644 cmake/Modules/FindEGL.cmake
|
|
create mode 100644 deps/glad/include/glad/glad_egl.h
|
|
create mode 100644 deps/glad/src/glad_egl.c
|
|
|
|
diff --git a/cmake/Modules/FindEGL.cmake b/cmake/Modules/FindEGL.cmake
|
|
new file mode 100644
|
|
index 00000000..ee27cc90
|
|
--- /dev/null
|
|
+++ b/cmake/Modules/FindEGL.cmake
|
|
@@ -0,0 +1,53 @@
|
|
+# - Try to Find EGL
|
|
+# Once done, this will define
|
|
+#
|
|
+# EGL_FOUND - system has EGL installed.
|
|
+# EGL_INCLUDE_DIRS - directories which contain the EGL headers.
|
|
+# EGL_LIBRARIES - libraries required to link against EGL.
|
|
+# EGL_DEFINITIONS - Compiler switches required for using EGL.
|
|
+#
|
|
+# Copyright (C) 2012 Intel Corporation. All rights reserved.
|
|
+# 2020 Georges Basile Stavracas Neto
|
|
+#
|
|
+# Redistribution and use in source and binary forms, with or without
|
|
+# modification, are permitted provided that the following conditions
|
|
+# are met:
|
|
+# 1. Redistributions of source code must retain the above copyright
|
|
+# notice, this list of conditions and the following disclaimer.
|
|
+# 2. Redistributions in binary form must reproduce the above copyright
|
|
+# notice, this list of conditions and the following disclaimer in the
|
|
+# documentation and/or other materials provided with the distribution.
|
|
+#
|
|
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND ITS CONTRIBUTORS ``AS
|
|
+# IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
|
|
+# THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
|
|
+# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR ITS
|
|
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
|
|
+# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
|
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
|
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
|
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
|
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
|
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+
|
|
+
|
|
+find_package(PkgConfig)
|
|
+
|
|
+pkg_check_modules(PC_EGL egl)
|
|
+
|
|
+if (PC_EGL_FOUND)
|
|
+ set(EGL_DEFINITIONS ${PC_EGL_CFLAGS_OTHER})
|
|
+endif ()
|
|
+
|
|
+find_path(EGL_INCLUDE_DIRS NAMES EGL/egl.h
|
|
+ HINTS ${PC_EGL_INCLUDE_DIR} ${PC_EGL_INCLUDE_DIRS}
|
|
+)
|
|
+
|
|
+find_library(EGL_LIBRARIES NAMES egl EGL
|
|
+ HINTS ${PC_EGL_LIBRARY_DIRS}
|
|
+)
|
|
+
|
|
+include(FindPackageHandleStandardArgs)
|
|
+FIND_PACKAGE_HANDLE_STANDARD_ARGS(EGL DEFAULT_MSG EGL_INCLUDE_DIRS EGL_LIBRARIES)
|
|
+
|
|
+mark_as_advanced(EGL_INCLUDE_DIRS EGL_LIBRARIES)
|
|
diff --git a/deps/glad/CMakeLists.txt b/deps/glad/CMakeLists.txt
|
|
index 2c4cf13a..9cb7e8fd 100644
|
|
--- a/deps/glad/CMakeLists.txt
|
|
+++ b/deps/glad/CMakeLists.txt
|
|
@@ -4,6 +4,7 @@ find_package(OpenGL)
|
|
|
|
if(NOT WIN32 AND NOT APPLE)
|
|
find_package(X11)
|
|
+ find_package(EGL REQUIRED)
|
|
endif()
|
|
|
|
set(glad_SOURCES
|
|
@@ -19,7 +20,9 @@ if(WIN32)
|
|
obsglad.rc)
|
|
elseif(NOT APPLE)
|
|
set(glad_PLATFORM_SOURCES
|
|
+ src/glad_egl.c
|
|
src/glad_glx.c
|
|
+ include/glad/glad_egl.h
|
|
include/glad/glad_glx.h)
|
|
endif()
|
|
|
|
@@ -28,7 +31,9 @@ set(glad_include_dirs
|
|
|
|
if (UNIX AND NOT APPLE)
|
|
list (APPEND glad_include_dirs
|
|
- PRIVATE ${X11_X11_INCLUDE_PATH})
|
|
+ PRIVATE
|
|
+ ${X11_X11_INCLUDE_PATH}
|
|
+ ${EGL_INCLUDE_DIRS})
|
|
endif()
|
|
|
|
add_library(glad SHARED
|
|
@@ -54,7 +59,9 @@ endif()
|
|
|
|
if(NOT WIN32 AND NOT APPLE)
|
|
set(glad_PLATFORM_DEPS
|
|
- ${X11_X11_LIB})
|
|
+ ${X11_X11_LIB}
|
|
+ ${EGL_LIBRARIES})
|
|
+
|
|
# only link to libdl on linux
|
|
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
|
set(glad_PLATFORM_DEPS
|
|
diff --git a/deps/glad/include/glad/glad_egl.h b/deps/glad/include/glad/glad_egl.h
|
|
new file mode 100644
|
|
index 00000000..ac07814e
|
|
--- /dev/null
|
|
+++ b/deps/glad/include/glad/glad_egl.h
|
|
@@ -0,0 +1,385 @@
|
|
+/*
|
|
+
|
|
+ EGL loader generated by glad 0.1.33 on Thu Aug 27 19:18:06 2020.
|
|
+
|
|
+ Language/Generator: C/C++
|
|
+ Specification: egl
|
|
+ APIs: egl=1.5
|
|
+ Profile: -
|
|
+ Extensions:
|
|
+ EGL_EXT_platform_wayland,
|
|
+ EGL_EXT_platform_x11,
|
|
+ EGL_KHR_create_context,
|
|
+ EGL_KHR_create_context_no_error,
|
|
+ EGL_KHR_platform_wayland,
|
|
+ EGL_KHR_platform_x11
|
|
+ Loader: True
|
|
+ Local files: False
|
|
+ Omit khrplatform: False
|
|
+ Reproducible: False
|
|
+
|
|
+ Commandline:
|
|
+ --api="egl=1.5" --generator="c" --spec="egl" --extensions="EGL_EXT_platform_wayland,EGL_EXT_platform_x11,EGL_KHR_create_context,EGL_KHR_create_context_no_error,EGL_KHR_platform_wayland,EGL_KHR_platform_x11"
|
|
+ Online:
|
|
+ https://glad.dav1d.de/#language=c&specification=egl&loader=on&api=egl%3D1.5&extensions=EGL_EXT_platform_wayland&extensions=EGL_EXT_platform_x11&extensions=EGL_KHR_create_context&extensions=EGL_KHR_create_context_no_error&extensions=EGL_KHR_platform_wayland&extensions=EGL_KHR_platform_x11
|
|
+*/
|
|
+
|
|
+
|
|
+#ifndef __glad_egl_h_
|
|
+
|
|
+#ifdef __egl_h_
|
|
+#error EGL header already included, remove this include, glad already provides it
|
|
+#endif
|
|
+
|
|
+#define __glad_egl_h_
|
|
+#define __egl_h_
|
|
+
|
|
+#if defined(_WIN32) && !defined(APIENTRY) && !defined(__CYGWIN__) && !defined(__SCITECH_SNAP__)
|
|
+#define APIENTRY __stdcall
|
|
+#endif
|
|
+
|
|
+#ifndef APIENTRY
|
|
+#define APIENTRY
|
|
+#endif
|
|
+#ifndef APIENTRYP
|
|
+#define APIENTRYP APIENTRY *
|
|
+#endif
|
|
+
|
|
+#ifdef __cplusplus
|
|
+extern "C" {
|
|
+#endif
|
|
+
|
|
+typedef void* (* GLADloadproc)(const char *name);
|
|
+
|
|
+#define GLAD_GLAPI_EXPORT
|
|
+
|
|
+#ifndef GLAPI
|
|
+# if defined(GLAD_GLAPI_EXPORT)
|
|
+# if defined(WIN32) || defined(__CYGWIN__)
|
|
+# if defined(GLAD_GLAPI_EXPORT_BUILD)
|
|
+# if defined(__GNUC__)
|
|
+# define GLAPI __attribute__ ((dllexport)) extern
|
|
+# else
|
|
+# define GLAPI __declspec(dllexport) extern
|
|
+# endif
|
|
+# else
|
|
+# if defined(__GNUC__)
|
|
+# define GLAPI __attribute__ ((dllimport)) extern
|
|
+# else
|
|
+# define GLAPI __declspec(dllimport) extern
|
|
+# endif
|
|
+# endif
|
|
+# elif defined(__GNUC__) && defined(GLAD_GLAPI_EXPORT_BUILD)
|
|
+# define GLAPI __attribute__ ((visibility ("default"))) extern
|
|
+# else
|
|
+# define GLAPI extern
|
|
+# endif
|
|
+# else
|
|
+# define GLAPI extern
|
|
+# endif
|
|
+#endif
|
|
+
|
|
+GLAPI int gladLoadEGL(void);
|
|
+GLAPI int gladLoadEGLLoader(GLADloadproc);
|
|
+
|
|
+#include <KHR/khrplatform.h>
|
|
+#include <EGL/eglplatform.h>
|
|
+struct AHardwareBuffer;
|
|
+struct wl_buffer;
|
|
+struct wl_display;
|
|
+struct wl_resource;
|
|
+typedef unsigned int EGLBoolean;
|
|
+typedef unsigned int EGLenum;
|
|
+typedef intptr_t EGLAttribKHR;
|
|
+typedef intptr_t EGLAttrib;
|
|
+typedef void *EGLClientBuffer;
|
|
+typedef void *EGLConfig;
|
|
+typedef void *EGLContext;
|
|
+typedef void *EGLDeviceEXT;
|
|
+typedef void *EGLDisplay;
|
|
+typedef void *EGLImage;
|
|
+typedef void *EGLImageKHR;
|
|
+typedef void *EGLLabelKHR;
|
|
+typedef void *EGLObjectKHR;
|
|
+typedef void *EGLOutputLayerEXT;
|
|
+typedef void *EGLOutputPortEXT;
|
|
+typedef void *EGLStreamKHR;
|
|
+typedef void *EGLSurface;
|
|
+typedef void *EGLSync;
|
|
+typedef void *EGLSyncKHR;
|
|
+typedef void *EGLSyncNV;
|
|
+typedef void (*__eglMustCastToProperFunctionPointerType)(void);
|
|
+typedef khronos_utime_nanoseconds_t EGLTimeKHR;
|
|
+typedef khronos_utime_nanoseconds_t EGLTime;
|
|
+typedef khronos_utime_nanoseconds_t EGLTimeNV;
|
|
+typedef khronos_utime_nanoseconds_t EGLuint64NV;
|
|
+typedef khronos_uint64_t EGLuint64KHR;
|
|
+typedef khronos_stime_nanoseconds_t EGLnsecsANDROID;
|
|
+typedef int EGLNativeFileDescriptorKHR;
|
|
+typedef khronos_ssize_t EGLsizeiANDROID;
|
|
+typedef void (*EGLSetBlobFuncANDROID) (const void *key, EGLsizeiANDROID keySize, const void *value, EGLsizeiANDROID valueSize);
|
|
+typedef EGLsizeiANDROID (*EGLGetBlobFuncANDROID) (const void *key, EGLsizeiANDROID keySize, void *value, EGLsizeiANDROID valueSize);
|
|
+struct EGLClientPixmapHI {
|
|
+ void *pData;
|
|
+ EGLint iWidth;
|
|
+ EGLint iHeight;
|
|
+ EGLint iStride;
|
|
+};
|
|
+typedef void (APIENTRY *EGLDEBUGPROCKHR)(EGLenum error,const char *command,EGLint messageType,EGLLabelKHR threadLabel,EGLLabelKHR objectLabel,const char* message);
|
|
+#define PFNEGLBINDWAYLANDDISPLAYWL PFNEGLBINDWAYLANDDISPLAYWLPROC
|
|
+#define PFNEGLUNBINDWAYLANDDISPLAYWL PFNEGLUNBINDWAYLANDDISPLAYWLPROC
|
|
+#define PFNEGLQUERYWAYLANDBUFFERWL PFNEGLQUERYWAYLANDBUFFERWLPROC
|
|
+#define PFNEGLCREATEWAYLANDBUFFERFROMIMAGEWL PFNEGLCREATEWAYLANDBUFFERFROMIMAGEWLPROC
|
|
+#define EGL_ALPHA_SIZE 0x3021
|
|
+#define EGL_BAD_ACCESS 0x3002
|
|
+#define EGL_BAD_ALLOC 0x3003
|
|
+#define EGL_BAD_ATTRIBUTE 0x3004
|
|
+#define EGL_BAD_CONFIG 0x3005
|
|
+#define EGL_BAD_CONTEXT 0x3006
|
|
+#define EGL_BAD_CURRENT_SURFACE 0x3007
|
|
+#define EGL_BAD_DISPLAY 0x3008
|
|
+#define EGL_BAD_MATCH 0x3009
|
|
+#define EGL_BAD_NATIVE_PIXMAP 0x300A
|
|
+#define EGL_BAD_NATIVE_WINDOW 0x300B
|
|
+#define EGL_BAD_PARAMETER 0x300C
|
|
+#define EGL_BAD_SURFACE 0x300D
|
|
+#define EGL_BLUE_SIZE 0x3022
|
|
+#define EGL_BUFFER_SIZE 0x3020
|
|
+#define EGL_CONFIG_CAVEAT 0x3027
|
|
+#define EGL_CONFIG_ID 0x3028
|
|
+#define EGL_CORE_NATIVE_ENGINE 0x305B
|
|
+#define EGL_DEPTH_SIZE 0x3025
|
|
+#define EGL_DONT_CARE EGL_CAST(EGLint,-1)
|
|
+#define EGL_DRAW 0x3059
|
|
+#define EGL_EXTENSIONS 0x3055
|
|
+#define EGL_FALSE 0
|
|
+#define EGL_GREEN_SIZE 0x3023
|
|
+#define EGL_HEIGHT 0x3056
|
|
+#define EGL_LARGEST_PBUFFER 0x3058
|
|
+#define EGL_LEVEL 0x3029
|
|
+#define EGL_MAX_PBUFFER_HEIGHT 0x302A
|
|
+#define EGL_MAX_PBUFFER_PIXELS 0x302B
|
|
+#define EGL_MAX_PBUFFER_WIDTH 0x302C
|
|
+#define EGL_NATIVE_RENDERABLE 0x302D
|
|
+#define EGL_NATIVE_VISUAL_ID 0x302E
|
|
+#define EGL_NATIVE_VISUAL_TYPE 0x302F
|
|
+#define EGL_NONE 0x3038
|
|
+#define EGL_NON_CONFORMANT_CONFIG 0x3051
|
|
+#define EGL_NOT_INITIALIZED 0x3001
|
|
+#define EGL_NO_CONTEXT EGL_CAST(EGLContext,0)
|
|
+#define EGL_NO_DISPLAY EGL_CAST(EGLDisplay,0)
|
|
+#define EGL_NO_SURFACE EGL_CAST(EGLSurface,0)
|
|
+#define EGL_PBUFFER_BIT 0x0001
|
|
+#define EGL_PIXMAP_BIT 0x0002
|
|
+#define EGL_READ 0x305A
|
|
+#define EGL_RED_SIZE 0x3024
|
|
+#define EGL_SAMPLES 0x3031
|
|
+#define EGL_SAMPLE_BUFFERS 0x3032
|
|
+#define EGL_SLOW_CONFIG 0x3050
|
|
+#define EGL_STENCIL_SIZE 0x3026
|
|
+#define EGL_SUCCESS 0x3000
|
|
+#define EGL_SURFACE_TYPE 0x3033
|
|
+#define EGL_TRANSPARENT_BLUE_VALUE 0x3035
|
|
+#define EGL_TRANSPARENT_GREEN_VALUE 0x3036
|
|
+#define EGL_TRANSPARENT_RED_VALUE 0x3037
|
|
+#define EGL_TRANSPARENT_RGB 0x3052
|
|
+#define EGL_TRANSPARENT_TYPE 0x3034
|
|
+#define EGL_TRUE 1
|
|
+#define EGL_VENDOR 0x3053
|
|
+#define EGL_VERSION 0x3054
|
|
+#define EGL_WIDTH 0x3057
|
|
+#define EGL_WINDOW_BIT 0x0004
|
|
+#define EGL_BACK_BUFFER 0x3084
|
|
+#define EGL_BIND_TO_TEXTURE_RGB 0x3039
|
|
+#define EGL_BIND_TO_TEXTURE_RGBA 0x303A
|
|
+#define EGL_CONTEXT_LOST 0x300E
|
|
+#define EGL_MIN_SWAP_INTERVAL 0x303B
|
|
+#define EGL_MAX_SWAP_INTERVAL 0x303C
|
|
+#define EGL_MIPMAP_TEXTURE 0x3082
|
|
+#define EGL_MIPMAP_LEVEL 0x3083
|
|
+#define EGL_NO_TEXTURE 0x305C
|
|
+#define EGL_TEXTURE_2D 0x305F
|
|
+#define EGL_TEXTURE_FORMAT 0x3080
|
|
+#define EGL_TEXTURE_RGB 0x305D
|
|
+#define EGL_TEXTURE_RGBA 0x305E
|
|
+#define EGL_TEXTURE_TARGET 0x3081
|
|
+#define EGL_ALPHA_FORMAT 0x3088
|
|
+#define EGL_ALPHA_FORMAT_NONPRE 0x308B
|
|
+#define EGL_ALPHA_FORMAT_PRE 0x308C
|
|
+#define EGL_ALPHA_MASK_SIZE 0x303E
|
|
+#define EGL_BUFFER_PRESERVED 0x3094
|
|
+#define EGL_BUFFER_DESTROYED 0x3095
|
|
+#define EGL_CLIENT_APIS 0x308D
|
|
+#define EGL_COLORSPACE 0x3087
|
|
+#define EGL_COLORSPACE_sRGB 0x3089
|
|
+#define EGL_COLORSPACE_LINEAR 0x308A
|
|
+#define EGL_COLOR_BUFFER_TYPE 0x303F
|
|
+#define EGL_CONTEXT_CLIENT_TYPE 0x3097
|
|
+#define EGL_DISPLAY_SCALING 10000
|
|
+#define EGL_HORIZONTAL_RESOLUTION 0x3090
|
|
+#define EGL_LUMINANCE_BUFFER 0x308F
|
|
+#define EGL_LUMINANCE_SIZE 0x303D
|
|
+#define EGL_OPENGL_ES_BIT 0x0001
|
|
+#define EGL_OPENVG_BIT 0x0002
|
|
+#define EGL_OPENGL_ES_API 0x30A0
|
|
+#define EGL_OPENVG_API 0x30A1
|
|
+#define EGL_OPENVG_IMAGE 0x3096
|
|
+#define EGL_PIXEL_ASPECT_RATIO 0x3092
|
|
+#define EGL_RENDERABLE_TYPE 0x3040
|
|
+#define EGL_RENDER_BUFFER 0x3086
|
|
+#define EGL_RGB_BUFFER 0x308E
|
|
+#define EGL_SINGLE_BUFFER 0x3085
|
|
+#define EGL_SWAP_BEHAVIOR 0x3093
|
|
+#define EGL_UNKNOWN EGL_CAST(EGLint,-1)
|
|
+#define EGL_VERTICAL_RESOLUTION 0x3091
|
|
+#define EGL_CONFORMANT 0x3042
|
|
+#define EGL_CONTEXT_CLIENT_VERSION 0x3098
|
|
+#define EGL_MATCH_NATIVE_PIXMAP 0x3041
|
|
+#define EGL_OPENGL_ES2_BIT 0x0004
|
|
+#define EGL_VG_ALPHA_FORMAT 0x3088
|
|
+#define EGL_VG_ALPHA_FORMAT_NONPRE 0x308B
|
|
+#define EGL_VG_ALPHA_FORMAT_PRE 0x308C
|
|
+#define EGL_VG_ALPHA_FORMAT_PRE_BIT 0x0040
|
|
+#define EGL_VG_COLORSPACE 0x3087
|
|
+#define EGL_VG_COLORSPACE_sRGB 0x3089
|
|
+#define EGL_VG_COLORSPACE_LINEAR 0x308A
|
|
+#define EGL_VG_COLORSPACE_LINEAR_BIT 0x0020
|
|
+#define EGL_DEFAULT_DISPLAY EGL_CAST(EGLNativeDisplayType,0)
|
|
+#define EGL_MULTISAMPLE_RESOLVE_BOX_BIT 0x0200
|
|
+#define EGL_MULTISAMPLE_RESOLVE 0x3099
|
|
+#define EGL_MULTISAMPLE_RESOLVE_DEFAULT 0x309A
|
|
+#define EGL_MULTISAMPLE_RESOLVE_BOX 0x309B
|
|
+#define EGL_OPENGL_API 0x30A2
|
|
+#define EGL_OPENGL_BIT 0x0008
|
|
+#define EGL_SWAP_BEHAVIOR_PRESERVED_BIT 0x0400
|
|
+#define EGL_CONTEXT_MAJOR_VERSION 0x3098
|
|
+#define EGL_CONTEXT_MINOR_VERSION 0x30FB
|
|
+#define EGL_CONTEXT_OPENGL_PROFILE_MASK 0x30FD
|
|
+#define EGL_CONTEXT_OPENGL_RESET_NOTIFICATION_STRATEGY 0x31BD
|
|
+#define EGL_NO_RESET_NOTIFICATION 0x31BE
|
|
+#define EGL_LOSE_CONTEXT_ON_RESET 0x31BF
|
|
+#define EGL_CONTEXT_OPENGL_CORE_PROFILE_BIT 0x00000001
|
|
+#define EGL_CONTEXT_OPENGL_COMPATIBILITY_PROFILE_BIT 0x00000002
|
|
+#define EGL_CONTEXT_OPENGL_DEBUG 0x31B0
|
|
+#define EGL_CONTEXT_OPENGL_FORWARD_COMPATIBLE 0x31B1
|
|
+#define EGL_CONTEXT_OPENGL_ROBUST_ACCESS 0x31B2
|
|
+#define EGL_OPENGL_ES3_BIT 0x00000040
|
|
+#define EGL_CL_EVENT_HANDLE 0x309C
|
|
+#define EGL_SYNC_CL_EVENT 0x30FE
|
|
+#define EGL_SYNC_CL_EVENT_COMPLETE 0x30FF
|
|
+#define EGL_SYNC_PRIOR_COMMANDS_COMPLETE 0x30F0
|
|
+#define EGL_SYNC_TYPE 0x30F7
|
|
+#define EGL_SYNC_STATUS 0x30F1
|
|
+#define EGL_SYNC_CONDITION 0x30F8
|
|
+#define EGL_SIGNALED 0x30F2
|
|
+#define EGL_UNSIGNALED 0x30F3
|
|
+#define EGL_SYNC_FLUSH_COMMANDS_BIT 0x0001
|
|
+#define EGL_FOREVER 0xFFFFFFFFFFFFFFFF
|
|
+#define EGL_TIMEOUT_EXPIRED 0x30F5
|
|
+#define EGL_CONDITION_SATISFIED 0x30F6
|
|
+#define EGL_NO_SYNC EGL_CAST(EGLSync,0)
|
|
+#define EGL_SYNC_FENCE 0x30F9
|
|
+#define EGL_GL_COLORSPACE 0x309D
|
|
+#define EGL_GL_COLORSPACE_SRGB 0x3089
|
|
+#define EGL_GL_COLORSPACE_LINEAR 0x308A
|
|
+#define EGL_GL_RENDERBUFFER 0x30B9
|
|
+#define EGL_GL_TEXTURE_2D 0x30B1
|
|
+#define EGL_GL_TEXTURE_LEVEL 0x30BC
|
|
+#define EGL_GL_TEXTURE_3D 0x30B2
|
|
+#define EGL_GL_TEXTURE_ZOFFSET 0x30BD
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_POSITIVE_X 0x30B3
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_NEGATIVE_X 0x30B4
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_POSITIVE_Y 0x30B5
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_NEGATIVE_Y 0x30B6
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_POSITIVE_Z 0x30B7
|
|
+#define EGL_GL_TEXTURE_CUBE_MAP_NEGATIVE_Z 0x30B8
|
|
+#define EGL_IMAGE_PRESERVED 0x30D2
|
|
+#define EGL_NO_IMAGE EGL_CAST(EGLImage,0)
|
|
+EGLBoolean eglChooseConfig(EGLDisplay dpy, const EGLint *attrib_list, EGLConfig *configs, EGLint config_size, EGLint *num_config);
|
|
+EGLBoolean eglCopyBuffers(EGLDisplay dpy, EGLSurface surface, EGLNativePixmapType target);
|
|
+EGLContext eglCreateContext(EGLDisplay dpy, EGLConfig config, EGLContext share_context, const EGLint *attrib_list);
|
|
+EGLSurface eglCreatePbufferSurface(EGLDisplay dpy, EGLConfig config, const EGLint *attrib_list);
|
|
+EGLSurface eglCreatePixmapSurface(EGLDisplay dpy, EGLConfig config, EGLNativePixmapType pixmap, const EGLint *attrib_list);
|
|
+EGLSurface eglCreateWindowSurface(EGLDisplay dpy, EGLConfig config, EGLNativeWindowType win, const EGLint *attrib_list);
|
|
+EGLBoolean eglDestroyContext(EGLDisplay dpy, EGLContext ctx);
|
|
+EGLBoolean eglDestroySurface(EGLDisplay dpy, EGLSurface surface);
|
|
+EGLBoolean eglGetConfigAttrib(EGLDisplay dpy, EGLConfig config, EGLint attribute, EGLint *value);
|
|
+EGLBoolean eglGetConfigs(EGLDisplay dpy, EGLConfig *configs, EGLint config_size, EGLint *num_config);
|
|
+EGLDisplay eglGetCurrentDisplay(void);
|
|
+EGLSurface eglGetCurrentSurface(EGLint readdraw);
|
|
+EGLDisplay eglGetDisplay(EGLNativeDisplayType display_id);
|
|
+EGLint eglGetError(void);
|
|
+__eglMustCastToProperFunctionPointerType eglGetProcAddress(const char *procname);
|
|
+EGLBoolean eglInitialize(EGLDisplay dpy, EGLint *major, EGLint *minor);
|
|
+EGLBoolean eglMakeCurrent(EGLDisplay dpy, EGLSurface draw, EGLSurface read, EGLContext ctx);
|
|
+EGLBoolean eglQueryContext(EGLDisplay dpy, EGLContext ctx, EGLint attribute, EGLint *value);
|
|
+const char *eglQueryString(EGLDisplay dpy, EGLint name);
|
|
+EGLBoolean eglQuerySurface(EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint *value);
|
|
+EGLBoolean eglSwapBuffers(EGLDisplay dpy, EGLSurface surface);
|
|
+EGLBoolean eglTerminate(EGLDisplay dpy);
|
|
+EGLBoolean eglWaitGL(void);
|
|
+EGLBoolean eglWaitNative(EGLint engine);
|
|
+EGLBoolean eglBindTexImage(EGLDisplay dpy, EGLSurface surface, EGLint buffer);
|
|
+EGLBoolean eglReleaseTexImage(EGLDisplay dpy, EGLSurface surface, EGLint buffer);
|
|
+EGLBoolean eglSurfaceAttrib(EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint value);
|
|
+EGLBoolean eglSwapInterval(EGLDisplay dpy, EGLint interval);
|
|
+EGLBoolean eglBindAPI(EGLenum api);
|
|
+EGLenum eglQueryAPI(void);
|
|
+EGLSurface eglCreatePbufferFromClientBuffer(EGLDisplay dpy, EGLenum buftype, EGLClientBuffer buffer, EGLConfig config, const EGLint *attrib_list);
|
|
+EGLBoolean eglReleaseThread(void);
|
|
+EGLBoolean eglWaitClient(void);
|
|
+EGLContext eglGetCurrentContext(void);
|
|
+EGLSync eglCreateSync(EGLDisplay dpy, EGLenum type, const EGLAttrib *attrib_list);
|
|
+EGLBoolean eglDestroySync(EGLDisplay dpy, EGLSync sync);
|
|
+EGLint eglClientWaitSync(EGLDisplay dpy, EGLSync sync, EGLint flags, EGLTime timeout);
|
|
+EGLBoolean eglGetSyncAttrib(EGLDisplay dpy, EGLSync sync, EGLint attribute, EGLAttrib *value);
|
|
+EGLImage eglCreateImage(EGLDisplay dpy, EGLContext ctx, EGLenum target, EGLClientBuffer buffer, const EGLAttrib *attrib_list);
|
|
+EGLBoolean eglDestroyImage(EGLDisplay dpy, EGLImage image);
|
|
+EGLDisplay eglGetPlatformDisplay(EGLenum platform, void *native_display, const EGLAttrib *attrib_list);
|
|
+EGLSurface eglCreatePlatformWindowSurface(EGLDisplay dpy, EGLConfig config, void *native_window, const EGLAttrib *attrib_list);
|
|
+EGLSurface eglCreatePlatformPixmapSurface(EGLDisplay dpy, EGLConfig config, void *native_pixmap, const EGLAttrib *attrib_list);
|
|
+EGLBoolean eglWaitSync(EGLDisplay dpy, EGLSync sync, EGLint flags);
|
|
+#define EGL_PLATFORM_WAYLAND_EXT 0x31D8
|
|
+#define EGL_PLATFORM_X11_EXT 0x31D5
|
|
+#define EGL_PLATFORM_X11_SCREEN_EXT 0x31D6
|
|
+#define EGL_CONTEXT_MAJOR_VERSION_KHR 0x3098
|
|
+#define EGL_CONTEXT_MINOR_VERSION_KHR 0x30FB
|
|
+#define EGL_CONTEXT_FLAGS_KHR 0x30FC
|
|
+#define EGL_CONTEXT_OPENGL_PROFILE_MASK_KHR 0x30FD
|
|
+#define EGL_CONTEXT_OPENGL_RESET_NOTIFICATION_STRATEGY_KHR 0x31BD
|
|
+#define EGL_NO_RESET_NOTIFICATION_KHR 0x31BE
|
|
+#define EGL_LOSE_CONTEXT_ON_RESET_KHR 0x31BF
|
|
+#define EGL_CONTEXT_OPENGL_DEBUG_BIT_KHR 0x00000001
|
|
+#define EGL_CONTEXT_OPENGL_FORWARD_COMPATIBLE_BIT_KHR 0x00000002
|
|
+#define EGL_CONTEXT_OPENGL_ROBUST_ACCESS_BIT_KHR 0x00000004
|
|
+#define EGL_CONTEXT_OPENGL_CORE_PROFILE_BIT_KHR 0x00000001
|
|
+#define EGL_CONTEXT_OPENGL_COMPATIBILITY_PROFILE_BIT_KHR 0x00000002
|
|
+#define EGL_OPENGL_ES3_BIT_KHR 0x00000040
|
|
+#define EGL_CONTEXT_OPENGL_NO_ERROR_KHR 0x31B3
|
|
+#define EGL_PLATFORM_WAYLAND_KHR 0x31D8
|
|
+#define EGL_PLATFORM_X11_KHR 0x31D5
|
|
+#define EGL_PLATFORM_X11_SCREEN_KHR 0x31D6
|
|
+#ifndef EGL_EXT_platform_wayland
|
|
+#define EGL_EXT_platform_wayland 1
|
|
+#endif
|
|
+#ifndef EGL_EXT_platform_x11
|
|
+#define EGL_EXT_platform_x11 1
|
|
+#endif
|
|
+#ifndef EGL_KHR_create_context
|
|
+#define EGL_KHR_create_context 1
|
|
+#endif
|
|
+#ifndef EGL_KHR_create_context_no_error
|
|
+#define EGL_KHR_create_context_no_error 1
|
|
+#endif
|
|
+#ifndef EGL_KHR_platform_wayland
|
|
+#define EGL_KHR_platform_wayland 1
|
|
+#endif
|
|
+#ifndef EGL_KHR_platform_x11
|
|
+#define EGL_KHR_platform_x11 1
|
|
+#endif
|
|
+
|
|
+#ifdef __cplusplus
|
|
+}
|
|
+#endif
|
|
+
|
|
+#endif
|
|
diff --git a/deps/glad/src/glad_egl.c b/deps/glad/src/glad_egl.c
|
|
new file mode 100644
|
|
index 00000000..e3cd1fc2
|
|
--- /dev/null
|
|
+++ b/deps/glad/src/glad_egl.c
|
|
@@ -0,0 +1,48 @@
|
|
+/*
|
|
+
|
|
+ EGL loader generated by glad 0.1.33 on Mon Mar 9 17:01:26 2020.
|
|
+
|
|
+ Language/Generator: C/C++
|
|
+ Specification: egl
|
|
+ APIs: egl=1.5
|
|
+ Profile: -
|
|
+ Extensions:
|
|
+ EGL_EXT_platform_wayland,
|
|
+ EGL_EXT_platform_x11,
|
|
+ EGL_KHR_platform_wayland,
|
|
+ EGL_KHR_platform_x11
|
|
+ Loader: True
|
|
+ Local files: False
|
|
+ Omit khrplatform: False
|
|
+ Reproducible: False
|
|
+
|
|
+ Commandline:
|
|
+ --api="egl=1.5" --generator="c" --spec="egl" --extensions="EGL_EXT_platform_wayland,EGL_EXT_platform_x11,EGL_KHR_platform_wayland,EGL_KHR_platform_x11"
|
|
+ Online:
|
|
+ https://glad.dav1d.de/#language=c&specification=egl&loader=on&api=egl%3D1.5&extensions=EGL_EXT_platform_wayland&extensions=EGL_EXT_platform_x11&extensions=EGL_KHR_platform_wayland&extensions=EGL_KHR_platform_x11
|
|
+*/
|
|
+
|
|
+#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+#include <string.h>
|
|
+#include <glad/glad_egl.h>
|
|
+
|
|
+int gladLoadEGL(void) {
|
|
+ return gladLoadEGLLoader((GLADloadproc)eglGetProcAddress);
|
|
+}
|
|
+
|
|
+static int find_extensionsEGL(void) {
|
|
+ return 1;
|
|
+}
|
|
+
|
|
+static void find_coreEGL(void) {
|
|
+}
|
|
+
|
|
+int gladLoadEGLLoader(GLADloadproc load) {
|
|
+ (void) load;
|
|
+ find_coreEGL();
|
|
+
|
|
+ if (!find_extensionsEGL()) return 0;
|
|
+ return 1;
|
|
+}
|
|
+
|
|
--
|
|
2.28.0
|
|
|