1
0
Fork 0
mirror of https://gitlab.gnome.org/GNOME/calls.git synced 2024-05-14 09:09:28 +00:00
Purism-Calls/debian/rules
2020-12-05 15:39:49 +01:00

28 lines
562 B
Makefile
Executable file

#!/usr/bin/make -f
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifeq ($(filter nodoc,$(DEB_BUILD_PROFILES)),)
CONFIGURE_OPTS+=-Dgtk_doc=true
else
CONFIGURE_OPTS+=-Dgtk_doc=false
endif
%:
dh $@ -- -B_build
override_dh_auto_configure:
dh_auto_configure -- $(CONFIGURE_OPTS)
override_dh_auto_build:
dh_auto_build
ifeq ($(filter nodoc,$(DEB_BUILD_PROFILES)),)
# https://github.com/mesonbuild/meson/pull/2862
ninja -C _build/ calls-doc
endif
override_dh_auto_test:
ifeq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
xvfb-run ninja -C _build test
endif